MySB
Close Panel
64°F

FAQs

The MAPS application does not run with my web browser. What’s wrong?

The application is designed and tested to run on Microsoft Internet Explorer 8.0 (or higher) running Microsoft Silverlight 5.0. While the application will work with most other commonly used browsers (Firefox, Chrome, Safari, etc.), using other browsers may cause random issues. Users are encouraged to use IE 8.0 or higher with Silverlight 5.0.